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Welcome

Welcome to the Quick Windows Sequencer (QWS). This program lets you record, play and edit music using MIDI. For best results you should have a MIDI keyboard connected to your computer, but it is still possible to use QWS without a keyboard.

License

You may use QWS for your own personal use, you don't have to pay me or anything like that … unless you want to, of course (some people have)! I reserve the right to change this policy.

If you want to use QWS for commercial or business purposes, or you're just not sure whether you should be paying for QWS, please get in touch.

I may make updates to QWS from time to time. For the moment, the best way to find out about these is on the website or by subscribing to the QWS mailing list.

QWS is copyright © 2002-2022 by James Bowden, all rights reserved. This refers to the executable program, documentation (printed and/or electronic) and any data or other materials supplied as part of the QWS software package.

The author accepts no liability for your use of QWS. Put it this way: I use QWS and it works for me, but I can make no guarantee of any kind.

What a tragic age when this sort of horrible legal disclaimer has to be put on everything just in case your dog bites you as a direct or indirect result of your use or inability to use something.

QWS should work in Windows 98, NT, 2000, XP, 7 and 10. It probably works in other flavours of Windows too, just I haven't ever tried so can't say for sure.

I'm sorry for you reading this page, because this sort of stuff really annoys me - especially as now I'm writing it!

If you do have problems, questions or comments, you can contact me and I'll try to help. However, please read this manual first.

Now that's over, let's get on with the rest of the manual.

What's New

Version 1.57:
· Insert From File command tool
· LFO settings and filter duplicates option in Progression tool
· Track Statistics now shows results in a list box

Version 1.56:
· Page Up and Page Down for Back and Next in Event List
· Max and min stats for notes in Track Statistics
· Insert event in Event List now defaults to track channel.
· Improvements for loading and using translatable prompts
· Bug fixes

Version 1.55:
· Length split and Reverse tools
· Added a percentage parameter to the Set Length tool
· Preview of notes as you move onto them in the Event List
· More Note Transforms
· Create your own User Note Transforms

Version 1.54:
· Tip of the day
· Added base key in note transform tool
· More keyboard commands
· Bug fixes

Version 1.53:
· Right click (context) menus
· Hotkey CTRL+SHIFT+V for Merge function
· Clear all markers command
· Event list editor now shows note names as well as numbers
· Multi-note transpose (transform) tool
· Auto cleanup on load option
· Auto send reset or initial track settings on load option
· QWS on the web help command
· Bug fixes.

Version 1.52:
· QWS user interface is now translatable.
· Added swing parameter to quantise function.
· HTML help.
· Bug fixes.

Version 1.51:
· Display and enter MIDI note names as well as numbers in various dialogs.
· Accept MIDI input in various dialogs.
· Enter chords as well as single notes when step recording.
· Allow octave 0 for onscreen keyboard.
· Option to automatically send MIDI local off and local on messages.

Version 1.50:
· GM2 reset command
· Display program and bank numbers as well as instrument list in Track Properties dialog
· CTRL+LEFT and CTRL+RIGHT in Track View move to next and previous data
· HOME and END in Track View move to first and last data
· Various bug fixes

Version 1.49:
· Corrected major version number to 1.
· Song properties now also displays song statistics (total time, bars, tracks, total events)
· Goto command now accepts position/bar/time
· View position on status bar as position/bar/time
· Local on/off commands
· Define Onscreen Keyboard keys
· Find Next command displays Find dialog if no previous find

Version 0.48:
· Change Properties function
· Stricter incoming MIDI filtering
· Send button in Sysex Editor
· Install program
· Bug fixes

Version 0.47:
· Progression tool
· Velocity crescendo tool
· Reorganised Tools menu
· Reset Apply to all tracks and punch recording on new

Version 0.46:
· Bug fixes

Version 0.45:
· Bug fixes

Version 0.44:
· Bug fixes
· Status bars in Note and Controller editors now show Ins or Mod
· Time signatures now up to 32/32
· Confirm Open, New and Exit dialog now works in more conventional way
· Scan folder for Instrument Lists, no need for INSTLIST section in qws.ini

Version 0.43:
· CTRL+C and CTRL+V copy and paste in system exclusive editor
· Onscreen Keyboard function
· Song Properties command
· Quantise Note Length tool
· Velocity Split tool
· Help file grown some more

Version 0.42:
· MIDI Clock function
· Various bug fixes
· Speed up reading instrument lists
· Help file grown a little more

Acknowledgements

Many thanks to those who spent hours trying various beta versions of QWS. They're still talking to me I think so it can't have been too bad.

In particular my thanks to André Louis for his enthusiasm, encouragement and suggestions all the way.

Thanks also to Nick Adamson, Brian Olesen and Arthur Pirika for their input and feedback.

Thanks also to those on the QWS mailing list who are using QWS and who gave various suggestions for it.

My thanks to those who have generously provided instrument lists for QWS and those who translated the user interface of QWS into other languages.

Final thanks go to David Haubensack, the author of a DOS sequencer called QSEQ, from which I had many hours (or was it years) enjoyable music making and from which I obtained several ideas for this program.

If You Use a Screen Reader

A screen reader is a program that converts text that appears on a computer screen to speech, braille or both. QWS should work (be accessible) with screen reading software and has been tested with several packages. Hopefully you should just be able to use QWS without any special scripts, add-ons, macros or other special configurations. Here are a couple of tips which will help you get the most out of QWS with a screen reader:

All the commands for using QWS are on the menus, accessed using the Alt key. Many commands also have shortcut or accelerator keys; these are listed after each menu command. For example, the File Open command (File menu, then Open) has the shortcut of Ctrl+O.

Many screens in QWS have a status bar at the bottom which shows information about the current position. So, using the Read Status Bar (or Read Last Line) command of your screen reader will help review this information to keep you on track.

Contacting the Author

The online help for QWS is the main source of information about it and constitutes the user manual. I strongly urge that you read it … come on, I took the time to write it, didn't I?

However, you can always contact me if you want to. Probably best is e-mail. My address is jr.bowden@btinternet.com.

The dedicated QWS website is at http://qws.andrelouis.com and contains an articles page, FAQ page, audio tutorials and provides links to the QWS mailing list. The mailing list is a good way to stay informed about QWS and to exchange ideas with other QWS users.

The QWS website also has this online manual in a document format.

The Basics

If you already know the basics of MIDI, sequencing and related terminology, you may wish to skip ahead to Getting Started otherwise, please read on.
· What is MIDI?
· What is a sequencer?
· MIDI terminology

What is MIDI?

MIDI is a way for musical instruments to communicate with each other. Because it is digital, it is ideal for storing musical information on a computer.

Information sent via MIDI includes such things as "play the note middle C so loud", "Move the pitch bend wheel to centre", or "Select a piano sound". Of course, it is a lot faster than saying the words!

It is important to remember that MIDI information is the instructions of what to play (notes, pitch bends etc), not the actual sounds themselves. For this reason, a MIDI song file even for a long piece of music can be quite small. However, because MIDI is the instructions, not the sounds, you may find that playing the same piece on different instruments (keyboards, soundcards etc) will produce a slightly different performance.

What is a Sequencer?

A sequencer is the MIDI equivalent of a multi track tape recorder. Simply, you can ask a sequencer to listen to MIDI information (as you play your keyboard, for example) and record it. Then, the sequencer can play it back.

Move to another track and ask the sequencer to record again and you can record a second instrument. Soon you will build up a complete musical sound (an orchestra or a band of some form).

Because MIDI is digital information, it is possible to alter (edit) the data after it has been recorded with ease. For example, say you played a wrong note, just change it for the right one - or delete it. Or say a note is too quiet (or too loud), then just change its volume. Or perhaps you decide you want the music (or a part of the music) to be played in a different key: just transpose it.

QWS is a MIDI sequencer which offers you a range of recording and editing functions allowing you to create and save musical pieces. For best results you will need a keyboard or some other MIDI instrument connected to your computer so that you can record and play music, but you can still use most of the functions even without one. Many modern computer soundcards contain in-built synthesisers, so you may be able to play music even without a keyboard.

MIDI Terms

The following sections go through the terms used to describe MIDI. It is important to know these as you will need this information to use QWS to the full.
· Channels
· Ports
· Beats and Ticks
· Notes
· Controllers
· Programs
· Aftertouch
· Pitch bend
· System Exclusive messages

Channels

Most MIDI messages have a Channel associated with them, a bit like the channels on a television or radio. Each MIDI device can typically support up to sixteen channels, meaning 16 simultaneous independently controlled instruments.

For example, you could have a piano on channel 1, a bass on channel 2, a guitar on channel 3, and so on. Each instrument only plays MIDI messages on its channel.

Channel 10 is often used for drum kits or other percussive instruments.

When you start a MIDI composition, the first thing to do is determine what instruments you want on each channel.

Some keyboards can be set to respond to all channels (sometimes called multitimbral or OMNI mode) or respond to only one channel.

Ports

You may have several MIDI devices available on your computer. Some of these may be internal synthesisers while others will be external MIDI OUT connectors.

QWS calls these various different outputs ports. Each track you create in QWS will have an associated MIDI OUT port, that is, you can select which MIDI device will receive the MIDI messages recorded in the track.

This means that a song in QWS can take advantage of any MIDI OUT devices you may have, and even use multiple MIDI OUT ports in one song.

Beats and Ticks

In MIDI, note lengths are measured in ticks.

In QWS, time is measured in beats and ticks. QWS divides a beat into 192 ticks, so half a beat would be 96 ticks and so on.

Other sequencing packages may use a different number of ticks for a beat, QWS will automatically convert any MIDI file you load.

The number of ticks in a beat is often called the Ticks Per Quarter Note value (TPQN).

Notes
 
Whenever you play a note on your keyboard, two MIDI messages are sent: The Note On when you play the note and the Note Off when you release it. Notes are the most common sort of MIDI message.

Every note has two primary attributes: its pitch (which key you played) and its Velocity (how loud you played it).

It is worth knowing about Key Numbers (the pitch of MIDI notes) as you may find them helpful when operating QWS. The number of the middle C key (261.6 Hz) is 60. From this, lower notes have lower numbers and higher notes have larger numbers. So, the B just below Middle C is note number 59, B flat is 58, and so on. An increase of 12 is one octave (there are twelve semitones in an octave).

We also call Middle C C4. The number after the C tells us the octave of the note. The C one octave above Middle C is called C5 (note number 72, 523.3 Hz). Octaves run from C to B with the lowest C on a piano being C1 (so most 61 note keyboards start at note C2).

Velocity (note loudness) is a number from 1 to 127, 1 being the quietest (pianissimo) and 127 the loudest (fortissimo). The term Velocity probably dates from the early days of touch sensitive keyboards when there used to be two electrical contacts on each key. The speed of making these two contacts would determine how fast the key was moving and so the loudness of the note.

One important point to note is that the velocity of a note is the relative loudness of the note, not the absolute volume in decibels of the sound. For example, playing a note quietly with the main volume turned up is very different from playing the same note loudly with the volume turned down.

Controllers

Controller MIDI messages do not themselves produce any sound but alter the way sound is produced. Controllers include things like the sustain pedal on a piano, the modulation wheel on a keyboard and the volume (swell) pedal on an organ.

There are lots of controllers available (too many to list all of them here) but they all have the same basic form. Each controller has a number (its identification code if you like) and a value. MIDI messages are sent whenever the value changes. Most controllers have a range of 0 to 127, although the meaning depends on the controller. It is also worth noting that different keyboards recognise different controllers.

Here are a few controllers to be aware of:

Bank Select - controller 0: On some keyboards bank messages are used in conjunction with Program messages to select sounds. The range of values available depends on the keyboard.

Modulation - controller 1: This can take all values, 0 is no modulation and 127 is full. The modulation wheel is often used for such functions as vibrato, though each keyboard may use it differently.

Volume - controller 7: This sets the volume of the instrument, 127 is the loudest and 0 is the quietest (silent).

Pan - controller 10: This sets the stereo position of the instrument. Usually a value of 64 is centre, with lower values moving to the left and higher values to the right.

The sustain pedal (sometimes called Hold1) - controller 64. This controller has only two values: 0 for pedal off and 127 for pedal on.

Reverb - controller 91: Some keyboards use this to set the amount of reverb applied to an instrument.

Chorus - controller 93: Some keyboards use this to set the amount of chorus applied to an instrument.

For further details, consult the manual that came with your keyboard. At the back you should find a MIDI implementation chart which will list everything your keyboard recognises.

Programs

A Program Change MIDI message is an instruction to your keyboard to select a particular sound (patch). Program messages have a value between 0 and 127, allowing you to choose up to 128 different sounds.

To allow more than this number, Bank Select controller messages are often used in conjunction with Program messages. It is worth noting that on many keyboards, you should send the Bank message before the Program message for correct operation.

The sound chosen for each Program may depend on your keyboard, but there are several standards in common use: the GM (General MIDI), GS (Roland) and XG (Yamaha). If you use these standards, your composition will sound the same on another keyboard also supporting that standard.

Aftertouch

Aftertouch (sometimes called Pressure) is a feature on some keyboards when you can apply extra pressure to a note once it is held down. These keyboards use this feature to control additional functions which affect the sound, for example, to add vibrato or brightness.

There are two forms of Aftertouch: Polyphonic and Channel. Polyphonic Aftertouch allows each note to be controlled independently. Channel Aftertouch affects all notes being played by that instrument at once.

It is worth noting that not all keyboards support Aftertouch and the effect that Aftertouch may have may vary from sound to sound.

Pitch Bend

The Pitch Bend wheel on many keyboards allows you to change (bend) the pitch of notes. Operating the Bend wheel on your keyboard will send Pitch Bend MIDI messages.

A Pitch Bend message has a value to determine the position of the wheel. 0 is centre, with positive values raising the pitch and negative values lowering it. The total range for Pitch Bend messages is -8192 to +8191.

It is worth noting that Pitch Bend messages in themselves do not determine the distance in semitones that the pitch will be raised or lowered. Some keyboards allow you to set the Bend Range with other MIDI messages. Consult your keyboard manual for details. However, typical bend range is ±2 semitones. Thus, a Pitch Bend message of -8192 would lower the pitch by 2 semitones, -4096 (half of -8192) lowers the pitch by one semitone, and so on.

System Exclusive Messages

Unlike most other MIDI messages, System Exclusive messages are special instructions to your keyboard. Each keyboard or MIDI device has a different set of exclusive messages that it recognises.

System Exclusive messages often control things like the setup of your keyboard. One common use for System Exclusive messages is to define the user assignable sounds (patches) loaded into the memory of your keyboard. Another use is to back up the entire setup of your keyboard (this is often called a Bulk Dump message).

For details, see your keyboard manual.

Getting Started

This section describes the basic operation of QWS:
· the main screen
· Creating tracks
· Recording and Playing
· Loading and Saving
· Example song

Main Screen

The main screen of QWS is divided into four areas:

On the left is the Track List providing a summary of all the tracks in the current song.

To the right is the Track View running parallel with the Track List. This shows the basic structure of each track.

At the top of the screen is the toolbar. This gives quick access to frequently used QWS commands.

At the bottom of the screen is the Status Bar which shows the current track number and current song position.

Track List

The Track List shows a summary of the tracks in the current song. Each item in the list is one track.

Each item shows the track name, the MIDI channel used and the MIDI OUT port.

If you mute a track, an exclamation (!) will appear to the left of the track name.

If you solo a track, a plus (+) will appear to the left of the track name.

You can manipulate tracks using the commands in the Track menu.

Track View

The Track View shows the structure of each track. Think of it like a grid: vertically, it shows each track, in parallel with the Track List. Horizontally, it shows time, each character position is a certain number of beats (usually 4) defined by the Zoom number.

A blinking caret shows you the current song position. This position is also shown in the status bar.

The Track View uses the following characters: Blank space indicates no MIDI data. A star (*) indicates the presence of notes. A dot (.) indicates MIDI events other than notes (for example, controllers). At the end of each track is a bar (|).

As you operate QWS and record and edit your song, the Track View will reflect your editing.

Status Bar

The Status Bar at the bottom of the screen shows the current state of QWS. On the left is the currently selected track.

In the middle is the current song position. The position can be shown in beats, bars and beats or time. The first beat of the song is numbered 0. Use the Display Units command on the View menu to change how the song position is shown.

To the right, you will see the play/record indicator. This shows whether QWS is stopped, playing, recording or giving a count-in before recording.

There are also various other indicators showing whether the metronome is on, whether looping is on and whether punch recording is on.

Creating Tracks

When you first start QWS, your song has no tracks. The first thing to do is create at least one track to work with.

You can create a track using the Insert command on the Track menu. The newly created track will appear at the end of the Track List.

Each track has a number of properties associated with it, such as basic MIDI settings and the output port which it will use. You can check these settings and change them by using the Properties command on the Track menu.

Make sure that the MIDI output port and MIDI channel are set correctly. If not, you may hear no sound when you play.

Note: It is possible to set which MIDI output port QWS will choose by default for newly created tracks. See the section Configuring QWS for details.

Record and Play

Let's record something into a track.

First, make sure the correct track is highlighted in the Track List.

Next, make sure you are at the right position you want the recording to begin (the current position is shown in the Status Bar at the bottom).

You may find it helpful to have the Metronome switched on. You can turn the metronome on and off by pressing F4. The metronome indicator appears in the Status Bar when the metronome is on.

Finally, when you are ready to record, choose the Record command from the Play menu, or press CTRL+R to start recording. You get four beats count-in and then recording begins.

When you have finished, press SPACE to stop.

To play back your masterpiece, first move back to the start by pressing the CTRL+HOME key. Then, press SPACE to start playing.

Loading and Saving

If you want to save your song, so you can continue work on it at a later time, choose the Save command from the File menu.

You can also use the Save As command to save your song. Save As will always ask you for a file name.

To load a song, choose the Open command from the File menu. If you have not saved your existing song, QWS will remind you first and ask if you want to save it.

Example Song

There is an example MIDI file supplied with your QWS package called SONG001.MID. To load this, open the File menu and choose the Open command. A dialog will appear, select SONG001.MID from the displayed list. Then click OK.

QWS will confirm the successful loading of the song by showing the summary of the song in the Track List and Track View. In this case there is only one track.

To play the song, choose the Play command from the Play menu, or just press the spacebar. To stop, press the spacebar again. Notice that as you play the song, the position number in the Status Bar increases. By default, the position is measured in beats (you can change this using the Display Units command on the View menu).

Let's assume you want to record a little on the end of this song. First, make sure QWS is not playing, then move to the end of the song by pressing the CTRL+END key.

To record, select the Record command from the Play menu, or press CTRL+R. There is a count-in of 4 beats before you start.

Once you have finished, just press the spacebar. You will be asked if you want to keep the recording — it's up to you! If you do, your recording will be added to the song.

Just for fun, let's transpose the piece up from the key of C to D. To do this, we want to transpose the track up a tone (that is, two semitones). From the Tools menu, select the Transpose command. You will be asked for the number of semitones to transpose, enter 2 and choose OK.

To hear how the modified song sounds, press CTRL+HOME to move back to the start of the song and press SPACE to begin playback. Notice it is now in a higher key.

Perhaps you decide now that the original key was better after all. You could transpose the song again, this time giving -2 semitones to move down by a tone, but this time, we can use the Undo command on the Edit menu. Undo will reverse the most recent action, so by choosing Undo now, you return the song to the original key.

Suppose now, you would like to hear the piece played by a different instrument, for example, strings. To change the sound, in MIDI terms, you need to change the program. You can do this by choosing the Properties command from the Track menu. This calls up a dialog allowing you to change several basic MIDI settings and the track name, channel and output port. Try entering a value in the Program box then choose OK. If you have a GM compatible keyboard, the program number for strings is 48. When you play the song, it now uses a different sound. You can even change the program while the song is playing: Simply play the song, then choose Track Properties and enter the new value. While you are in the Track Properties dialog, you might like to experiment with the other controls as well.

After you have finished with the song, you might want to save the new version. To do this, choose the Save As command from the File menu. You will be asked for a name for the song. Type a name in the box and choose OK. The Save command on the File menu also saves the current song, but does not ask for a name. Save is useful for quickly backing up your work once you have saved it once.

To exit QWS, choose the Exit command from the File menu.

The remaining topics in this help file describe the functions of QWS in more detail. You can either read through this manual, or use it more as a reference.

Functions & Features

This section provides information on the main features and functions of QWS. All of these functions can be accessed through the menus. In addition, many features have shortcut keys as well.
· Playing
· Recording
· Local on/off
· Metronome
· MIDI Clock
· Synchro Start
· Onscreen Keyboard
· Muting
· Solo
· Unmute all
· Load & Save
· File Formats
· Moving Around
· Selecting
· Find & Goto
· Markers
· Loops
· Punch Recording
· Step Recording
· Song Properties
· Track Properties
· Time & Tempo
· Changing Track Properties
· Track Statistics
· Restoring Settings
· Cut & Paste
· Merge
· Delete & Clear
· Undo
· Rearranging Tracks
· Setting All Ports
· MIDI Resets

Playing

To play a song, choose the Play command from the Play menu, or press the Spacebar.

Playing will commence at the current position as shown in the status bar at the bottom of the main screen. This means you can continue playback where you last left off.

When you play a song, the word "Play" will appear in the status bar to the right of the position indicator to let you know that QWS is playing.

Of course, before you press Play, it is helpful to have a song loaded or to record some music first.

Recording

To record, choose the Record command from the Play menu, or press CTRL+R. This type of recording is sometimes called "Realtime Recording".

On the status bar, the word "Count-in" or "Rec" will appear to show the current state. Recording will begin once "Rec" appears.

You may find the metronome helpful in order to keep time.

To stop recording, Choose the Play command from the Play menu, or press the Spacebar. By default, QWS will ask you if you would like to keep your recording. If you answer Yes, your recording will be shown in the main track view.

After recording, the current position will be returned to the point where you started.

QWS also has other methods of recording, Punch Recording and Step Recording.

Local On/off

Normally when you play a keyboard, keys you press generate sound. The key press is also sent as a MIDI message to the sequencer. If you are using MIDI THRU on the sequencer, the sequencer will echo the MIDI message back to the keyboard. This can result in the note being played twice (a doubled note).

To allow just the sequencer to generate the sound, on many keyboards, you can make a setting called "local off".

QWS provides Local On and Local Off commands in the MIDI menu.

If you find yourself needing to use Local Off when using QWS to eliminate doubled notes, remember to use the Local On command when you have finished so you can play your keyboard normally again afterwards
Note: QWS also has an option so that local messages are sent automatically when you start and close QWS.

The Metronome

QWS has a metronome to help you keep time. If the metronome is switched on, the word "Metro" will appear in the status bar at the bottom of the main screen.

To turn the metronome on or off, choose the Metronome command from the MIDI menu, or press F4.

You can change the way the metronome sounds using the Metronome command in the Options menu. Also, the metronome is affected by the time signature and tempo of the song.

MIDI Clock

QWS can send a MIDI clock signal when playing or recording. This can help synchronise your MIDI equipment with QWS, if applicable. For example, on certain synthesisers, some sounds can be linked to a clock so that they play in time.

To turn the MIDI clock function of QWS on or off, simply choose the Clock command from the MIDI menu.

Synchro Start

You can make QWS begin song playback or start recording as soon as you start playing on your MIDI instrument. This function is called Synchro Start.

To turn Synchro start on or off, use the Synchro Start command on the Play menu, or press CTRL+Y.

Then, when you choose Play or Record from the Play menu, QWS will wait (the word "Synchro" will appear on the status bar) and will begin when you start playing.

Note: When Synchro start is turned on, metronome count-ins are not supplied.

Onscreen Keyboard

You can simulate MIDI input using the Onscreen Keyboard feature of QWS. This could be useful, for example, if you do not have a MIDI instrument connected to your computer.

To call up the Onscreen Keyboard, choose the Onscreen Keyboard command from the MIDI menu, or press F11.

The Onscreen keyboard will send MIDI messages to QWS, exactly as if you were playing a MIDI instrument connected to your computer. Therefore, if the MIDI THRU function is turned on, notes you play using the Onscreen Keyboard will be passed through to the current track.

When you are using the Onscreen Keyboard, you can either click the "keys" of the keyboard with the mouse or use the keys on your computer keyboard to play notes.

The two sliders below the "keyboard" display let you select the octave for the keyboard and the velocity (loudness) of the notes.

When using the computer keyboard, use the middle two rows of keys to play notes: by default, the A key plays C, S plays D, D plays E and so on. The top row of keys selects octave, pressing 4 for example will select fourth octave so that the A key will play note C4. The lower row of keys are used to select velocity. You can also use the SHIFT key to simulate a sustain pedal.

When you have finished with the Onscreen Keyboard, press the Close button (or ESCAPE) to return to the main screen.

Note: When you use the Onscreen Keyboard, you cannot use the main QWS menu. However, as the Onscreen Keyboard directly simulates the action of incoming MIDI messages, just as if you were playing a MIDI instrument connected to your computer, the Key Commands feature of QWS still operates.

Note: You can press more than one key at a time when using the Onscreen Keyboard. However, precisely how many keys you can press at once will depend on your computer keyboard's hardware: some keyboards will let you press many keys together but others will only allow two or three together.

Note: You can change which keys make notes on the onscreen keyboard using the Onscreen Keyboard command on the Options menu.

Muting

To mute a track so that it no longer plays, move to the track you wish to mute and choose the Mute command from the Track menu, or press the M key.

If a track is muted, an exclamation mark (!) will appear at the extreme left of the track name in the track list.

To unmute a track, follow the same procedure as above. The Mute command is a toggle command, that is, it will switch the mute state of the track.

Solo

Sometimes, you may wish to solo a particular track so that all the other tracks in your recording are silent. To do this, move to the track you wish to solo and choose the Solo command from the Track menu, or press the S key.

A plus sign (+) will appear at the extreme left of the track name in the track list.

You can only have one track solo at a time. If you try and solo a track while another track is already solo, the current solo track will return to its normal state.

Note that you can solo a track, even if it is normally muted.

Unmute All

The Unmute All command on the Track menu is a quick way to remove all mute and solo marks from all tracks so that they all play together.

Load and Save

The Open command on the File menu lets you load a MIDI file stored on your computer. When you load a file in this way, your existing song will first be cleared. If you have not saved any changes you have made, QWS will warn you about this.

Similar to the Open command, the Append command on the File menu loads a MIDI file, but does not clear your existing song. Instead, the new song is loaded by adding extra tracks to the end of the existing song.

To save the current song, choose the Save command from the File menu. If you have already given the file a name, QWS will immediately save the song without prompting. The Save command can be a quick way to make sure your work is stored.

The Save As command also saves the current song, but will ask you for a name for the file. If you use a name which has already been used, QWS will warn you of this.

At the bottom of the File menu, there are some numbered items. This is the Recent File List. You can choose these items to quickly reload a file that you have recently been working on. Whenever you load or save a file, the filename will be added to the Recent File List so you can load it more easily next time.

File Formats

When you use the Save As command from the File menu to save a file, below the box where you type the filename is a dropdown list which lets you select the file format you wish to use.

QWS supports several MIDI file formats as follows:

MIDI file Full QWS: This format is a MIDI type 1 file which additionally includes certain private codes so that QWS can store all the song's settings. The extra information stored includes the MIDI output port for each track and any mark and loop settings. Other sequencer packages should be able to read these files.

MIDI file Type 1: This is a standard Type 1 MIDI file which can be read by most sequencer packages. All song information is stored except MIDI output port, mark and loop settings.

MIDI file Type 0: This format merges all tracks into a single multichannel track. Some sequencers require this format.

System exclusive file: This file contains only system exclusive MIDI data. It strips out all other MIDI information so you save only the System Exclusive messages. It can be useful for saving device settings (for example from a Bulk Dump from a synthesiser).

Moving Around

As you work in QWS, you may wish at times to move to another position in the song. QWS has several ways of doing this, including basic movement, markers and loops.

The current song position (measured in beats) is shown in the status bar at the bottom of the screen. The first beat of the song is numbered 0. You can change the status bar to display bar numbers or time. To do this, use the Display Units command on the View menu.

The current position will advance when you play or record, but in addition, you can use the LEFT and RIGHT arrow keys to skip backwards and forwards. You can even do this while the song is playing!

Pressing CTRL+RIGHT or CTRL+LEFT will skip to the start of the next or previous section in the current track where there is data. This can be useful, for example, when you have a track that plays only at certain points in the song.

Pressing HOME or END will skip to the position where data starts or ends in the current track.

To move to the start or end of the song, press CTRL+HOME or CTRL+END.

To move between the various tracks in your song, use the UP and DOWN arrow keys, or the PGUP and PGDN keys.

Selecting

Some of the functions in QWS require you to select a portion of a track to operate on. This includes the Cut and Paste function and many of the Tools.

To select a portion of a track, simply hold down the SHIFT key and use the Movement keys.

If you want to unselect, just press a movement key without the SHIFT key.

Find & Goto
 
The Find command on the Goto menu allows you to search for particular MIDI events, such as a note, controller or tempo change. When you choose this command, a dialog will appear. Choose the type of MIDI event to look for from the list.

If you are looking for a note or controller, you can specify which particular note or controller to search for by entering a value in the box.

Finally, choose whether the search moves forwards or backwards from the current song position.

The Goto command on the Goto menu lets you jump to a particular place in your song. You can jump to a song position (beat number), a bar and beat number or a time.

If you choose a position, simply enter the position number in the box and choose the OK button; the first position is 0.

For bar numbers, separate the bar and beat number with a colon, for example 16:1. The beat number is optional and the first bar is 1.

For times, enter minutes, seconds and milliseconds as follows: 2:35.800. The minutes and millisecond portions are optional.

Note: The Find and Goto commands can be used at any time, even when you are playing the song.

Note: When jumping to bar and beat or time positions, the position you enter is resolved to the nearest song position number.

Markers

QWS allows you to set markers so that you can quickly jump to certain points in your song. There are twenty general markers (numbered 0-19) and two special markers (left and right).

To set a marker, first move to the point in the song where you want the marker, then choose the Set Marker command from the Goto menu. Choose the marker you wish to set from the list and then choose OK.

Alternatively, if you wish to set marker 0-9 or the left or right marker, move to the point where you want to set the marker and then press SHIFT + the number you want. For example, SHIFT+1 will set marker 1, SHIFT+R will set the right marker, and so on.

Use the Clear Marker command on the Goto menu to clear individual markers, or the Clear All Markers command to clear all the markers.

To jump to a marker, choose the Goto Marker command from the Goto menu. Alternatively, for markers 0-9 or the left or right marker, simply press the key for the marker. For example, 5 will jump to marker 5, L will jump to the left marker and so on.

You can set, clear or jump to markers at any time, even when you are playing the song.

Loops

You can set QWS to play a portion of your song over and over. This is called looping.

To set up a loop, set the left marker to the place where you want the loop to begin. Then, set the right marker to the end of the loop. Finally, select the Loop command from the Play menu (Loop will appear in the status bar to confirm that looping is enabled).

Now, whenever playback reaches the right marker, QWS will automatically jump back to the left marker.

You can also use looping in recording: When you do this, you repeatedly record the same place. Each time you record, the new recording is added to (merged with) the existing recording. This can be useful when recording drum patterns. For best results, turn off the option Confirm Keep Recordings in the Options. If this option is off, each time you loop, the recordings of previous loops will immediately be played back.

Punch Recording

With the left and right markers and the Punch Recording command in the Play menu, it is possible to set limits for a recording session.

When punch recording is turned on, the word Punch will appear in the status bar. Recording will then not occur before the left marker or after the right marker.

Punch recording can be especially useful when you want to record something close to an existing recording and you don't want to damage it. Set the left and/or right markers around the part you want to record, then turn punch recording on, then record. The recording will be confined to the marked region. Anything you play outside the marked region will not be saved.

Step Recording

Step recording means that every note you play will be set to a specified length, regardless of the speed you played it.

To start step recording, choose the Step Record command from the Play menu, or press CTRL+E.

A dialog will first appear to let you set the length of notes you play and the amount to move forward after each note (the step size). These values are given in ticks, there are 192 ticks per beat. For example, if you wanted to record 2 notes per beat with each note being a quarter of a beat long, the note length would be 48 (192/4) and the step size would be 96 (192/2).

Once you choose OK, the word "StepRec" will appear on the status bar to confirm step recording is in progress.

There is no metronome when step recording as every note is a set length: you can play as fast as you like.

You can enter single notes or chords when step recording. The recording moves forward when you release all notes you have held down.

To finish step recording, Choose the Play command from the Play menu, or press the Spacebar.

Song Properties

You can set the title and copyright information for your song by using the Song Properties command on the File menu. Simply enter the information into the boxes and choose OK. You do not have to use this if you don't want to, it is purely for information.

The Song Properties dialog also displays some general information about the song: the total number of tracks, the total number of MIDI events, the total number of bars and the total time of the song.

Note: In order for the time and bar totals to be accurate, all tempo and time signature events should be placed only on the first track. This is in accordance with the MIDI standard.

Track Properties

Each track in QWS has a number of properties that you can set. These generally give the initial MIDI settings for the track such as which instrument to use.

To edit the properties for a track, first select the track you want to edit, then from the Track menu choose Properties.

A dialog will appear showing the current settings for the track. Simply change them as appropriate. If you have the MIDI in Dialogs option turned on, you will be able to hear the effect of your changes as you edit in the properties dialog. Also, any settings you send from your MIDI instrument will be entered into the dialog.

You can also change settings throughout a track using the various Editors or with the Change Properties command on the Track menu.

The track properties are as follows:

Name: Enter the name for the track. The name will also appear in the Track List in the main screen.

Channel: Enter the MIDI channel for the track between 1 and 16. The channel number also appears in the Track List. If you want a track to contain data for multiple channels, set the MIDI channel in the Track Properties to 0.

Port: Select the MIDI OUT port for the track. The port also appears in the Track List.

Instrument: If you have selected an instrument list, you can select the instrument for the track by name using the list. When you select from the list, the Program and Bank numbers will change to show the appropriate values.

Program: Enter the MIDI program number for the track, between 0 and 127. A value of -1 means no program. If you have selected an instrument list, the instrument will also change as appropriate.

Bank: Select the MIDI bank number between 0 and 16383. The bank numbers to use will depend on your MIDI equipment. If you do not want to use a bank, set this value to -1. If you have selected an instrument list, the instrument will change as appropriate.

Volume: Select the volume for the track between 0 (silence) and 127 (maximum). If you do not want to set the volume then enter -1.

Pan: Select the pan (stereo position) for the track between 0 (extreme left) and 127 (extreme right), 64 is centre. If you do not want to set the pan, enter a value of -1.

Reverb: Set the reverb level for the track between 0 and 127. If you do not want to set the reverb, use a value of -1.

Chorus: Set the chorus level for the track between 0 and 127. If you do not want to set the chorus level, use a value of -1.

Time & Tempo Settings

You can set the initial time signature and tempo of your song by selecting the Initial Time & Tempo command from the Play menu. This calls up a dialog.

Tempo is measured in beats per minute. The higher the number, the faster the tempo. The time signature simply adjusts the way the metronome sounds.

Changing Track Properties

You can change many of the settings for a track at any point. The Change Properties command on the Track menu brings up a dialog very similar to the Initial Properties command, but will apply the settings you choose at the current point in the track.

The dialog shows the current settings at the position and allows you to adjust these as needed. If you have the MIDI in Dialogs option turned on, you will be able to hear the effect of your changes as you edit in the change properties dialog and any settings you send from your MIDI instrument will also be entered into the dialog.

A value of -1 for a setting means no change.

Track Statistics

The Statistics command on the Track menu displays some basic statistical information about a MIDI track, such as the total number of various MIDI events, for example the total number of notes in the track and the number of times the sustain pedal was used.

Track statistics can sometimes be useful to check why a track is behaving strangely: for example, if you have an odd number of sustain pedal messages, the chances are that the number of pedal down messages does not match the number of pedal up messages. Or, if the number of note off messages does not match the number of note on messages, some notes may carry on playing forever!

You can then use the editors or tools in QWS to help resolve this kind of problem.

Apart from being a diagnostic aid, the track statistics can also provide some interesting information about the track.

Restoring Settings

Sometimes, you may find you need to restore MIDI settings, i.e. send them to your MIDI instruments again. For example, if you were playing a song, stop it, move further on and resume playback, the MIDI settings may not be the same as they were at the point where you stopped playback.

QWS has two commands which let you restore the MIDI settings, both can be found on the Play menu.

The Send Initial Settings command sends all the MIDI settings that you have specified for each track's properties. These are the settings which will be sent at the very beginning of the song. In addition, aftertouch and pitch bend are reset.

The Send Current Settings command sends the latest settings based on the current song position. Settings which are sent include any MIDI controller settings, program changes, aftertouch, pitch bend, tempo and time signature.

Note: There is an Option to automatically send the initial track settings as soon as you load a song.

Cut & Paste

The Cut and Paste facility in QWS allows you to move or copy a block of MIDI data.

First, move to the start of the block of data you wish to cut or copy. Then, holding the SHIFT key, move to the end of the block. Then choose either the Cut or Copy command from the Edit menu.

Copy takes a copy of the selected block and keeps the block intact. By contrast, Cut takes a copy, then deletes the block from the original position.

When you cut or copy, the MIDI data of the original block is stored in the QWS clipboard. You can then Paste this anywhere and as often as you wish.

To Paste, move to the position where you want to paste then choose Paste from the Edit menu. The Paste command will make space in the track for the pasted material.

Similar to the Paste command, the Paste Multiple command lets you copy the same block a number of times.

Merge

The Merge command is very similar to the Paste command, except that it does not make room in the track before pasting. So, MIDI data will be pasted on top of the existing data in the track, allowing you to merge two recordings.

Beware that sometimes you may end up with doubled notes, that is, two of the same note playing at the same time. You may find the Cleanup Tool useful after merging.

Similar to the Merge command, the Merge Multiple command lets you merge the same block a number of times.

Delete & Clear

To delete a portion from a track, first select the portion and then choose the Delete command from the Edit menu. The portion will be removed and the remainder of the track will move backwards to fill the gap.

The Clear command on the Edit menu works in a similar way to Delete, but leaves a gap where the deleted material was.

Undo

QWS has an Undo feature. This means that if you make a mistake in your editing, you can choose the Undo command from the Edit menu and QWS will reverse the last edit.

You can undo most actions: recording, most of the tools, editing done in the editors, cutting or pasting. However, you can only undo the most recent operation: if you choose Undo a second time, this will undo the undo, putting back your edit.

Rearranging Tracks

You can change the order of the tracks in a song by using the Move command on the Track menu. First, select the track you wish to move. Then choose Move from the Track menu. You will be asked for the new track number. After entering this, choose OK and the track will be moved. All the tracks between the old and new track position will also be adjusted to fill the empty space (the old track position).

You can also use the Sort command on the Track menu to sort all tracks in a song into order. The order is based first on MIDI port, then channel, then name. So, all tracks having the same MIDI port are grouped together. Within each group, the tracks are arranged in channel order. If two tracks have the same port and channel, the track names will determine the order.

Note: If you use a tempo track (an empty track just containing tempo events), you may need to move this back to track 1 after you do a Track Sort.

Set All Ports

The Set All Ports command on the Track menu lets you change the MIDI OUT port for every track. When you choose this command, a dialog will appear listing all available ports. Choose the one you want and then OK. All the tracks will then use that Port.

Note: You can use the Properties command on the Track menu to change the port for individual tracks.

MIDI Reset

Several of the commands on the MIDI menu send various MIDI reset messages to your MIDI instruments.

The All Notes Off command sends a message to stop all notes from playing. This can be useful if a note "gets stuck".

The GM, GM2, GS and XG Reset commands send initialisation messages which set compatible MIDI instruments to a standard setting. For these messages to work, your MIDI instrument must be compatible with the reset.

Note: Consult the manual that came with your MIDI instrument to see if it responds to these reset messages.

Note: There is an Option to automatically send one of the MIDI reset commands whenever you load a song.

Tools

The tools in QWS offer many convenient functions for manipulating MIDI data. These are explained in the following sections.

Most of the tools will pop up a dialog to ask you for the parameters for the tool. In the following sections, this will be referred to as the input. If you need to enter a note as input to a tool, you can either enter a note name or a note number.

The tools normally operate on the current track. However, if you select the Apply to All command from the Tools menu, the tools will operate on all tracks which are not muted. Apply to All works with all tools except Channel Split, Key Split and Velocity Split.

If you have a selected region in a track, the tools operate only on the selected region. However, if no region is selected, the tools will operate on the entire track. The only exception to this is the Cleanup tool, which always operates on the entire track.

Remember, if you make a mistake with a tool, you can always undo the last operation using the Undo command on the Edit menu.
· Transpose
· Change velocity
· Time glide
· Time expand
· Quantise
· Quantise length
· Humanise
· Set length
· Legato
· Progression
· Insert from File
· Clean up
· Set channel
· Channel split
· Key split
· Velocity split
· Length split
· Note replace
· Velocity crescendo
· Controller renumber
· Change controllers
· Reverse
· Delete notes
· Delete controllers
· Note transform
· Apply to all tracks

Transpose

The Transpose tool adjusts the pitch of every note in the selected region by adding or subtracting a specified number of semitones. This changes the key of the selected region.

Input: Enter the number of semitones to transpose by. Positive values will transpose upwards, negative values will transpose downwards.

Note: It may be helpful to remember there are 12 semitones in a complete octave.

Change Velocity

The Change Velocity tool adjusts the volume of notes in the selected region. The velocity is adjusted by using a specified percentage of the current velocity and a fixed value.

Input: The percentage of the existing velocity to use. Giving a value greater than 100% will have the effect of making the playing more dynamic, giving a percentage less than 100% will reduce variations in playing dynamic.

The Fixed offset is a fixed velocity value to add or subtract from each note. Positive values will make the notes louder, negative values will make the playing quieter.

Note: Certain parameter combinations may exceed the allowed velocity range of 1 (quietest) to 127 (loudest). If this happens, velocity will be clipped to the minimum or maximum.

Time Glide

The Time Glide tool lets you move the selected region forward or backwards by a specified number of beats and ticks.

Input: The number of beats and ticks to move the selected region. Enter the number of beats followed by a dot followed by the number of ticks.

For example, to move the selected region forward half a beat (so it plays a bit later) enter 0.096.

Note: There are 192 ticks in a beat.

Time Expand

The Time Expand tool allows you to change the speed of the selected region.

Input: Percentage to stretch the selected region. Values greater than 100 will make the selected region play more slowly while values less than 100 will make it play more quickly.

For example, if you want to make the selected region play at half speed, that is, taking twice as long to play, enter 200.

Note: You may only enter whole number percentages. In some cases where fractions would be needed to achieve exact timing, you may wish to Quantise after using this tool.

Quantise

The Quantise tool is possibly one of the most important tools: use it to move notes which are not exactly in time (that is, accurately on the beat) to their correct positions, or to add a swing feel.

Input: The Beat Division is the number of positions within a beat which are considered acceptable. For example, to allow playing in semiquavers (sixteenth notes) you divide an ordinary beat (a crotchet or quarter note) into 4, so the Beat Division is 4.

The Percent Strictness parameter allows you to determine how rigid you want the quantising to be. For example, a strictness of 100 (%) will mean that all notes are moved to exact positions, no matter how far away they actually are. A strictness of 50 will move notes half the distance towards the exact positions and so on. A strictness of 0 will have no effect, as notes are moved none of the distance towards the exact positions.

The Percent Swing parameter lets you add a swing feel to the notes. If you set swing to 0 (%), no swing is applied. If you use 50 (%), notes will be swung so that they move half the distance to the next beat position. For example, if a note was the fourth semiquaver in a beat, i.e. at tick number 144 out of 192, it would be moved to 168.

You can also use negative swing numbers to move notes towards the beginning of the beat. Values for swing range from -100 to 100.

Tip: A strictness of 100 can in some cases lead to a mechanical performance. Sometimes it can help to set this to a slightly lower value to retain some musical character - but this depends on the style and the instrument.

Quantise Length

The Quantise Length tool is very similar to the Quantise tool, except that, rather than moving notes so that they start in time, it adjusts the lengths of notes so that they are accurate.

Input: The input to this tool is exactly the same as for Quantise. The Beat Division is the basis for acceptable note lengths. For example, to allow note lengths of multiples of semiquavers (sixteenth notes) you divide an ordinary beat (a crotchet or quarter note) into 4, so the Beat Division is 4.

The Percent Strictness parameter allows you to determine how rigid you want the length adjustments to be. For example, a strictness of 100 (%) will mean that all note lengths are adjusted to exact lengths, no matter how far away they actually are. A strictness of 50 will adjust note lengths half way towards the exact lengths and so on. A strictness of 0 will have no effect, as note lengths would be adjusted none of the way towards the exact lengths.

Tip: A strictness of 100 can sometimes be helpful if you intend to send the song data to another program, for example to produce printed music score.

Humanise

You can think of the Humanise tool as the opposite of Quantise: it adds or subtracts a random number of ticks from the start point of every note. This can give a less mechanical feel to the playing.

Input: The maximum number of ticks to add or subtract. Sensible values are probably between 1 and 6 ticks, depending on the musical style and instrument.

Note: Very large values for humanising may lead to undesirable results, with notes being in the wrong order.

Set Length

The Set Length tool adjusts the length of notes in the selected region. The note length is adjusted by using a specified percentage of the current length and a fixed value.

Input: The percentage of the existing note length to use.

The Fixed offset is a fixed length value in beats and ticks to add or subtract from each note length.

For example, if you wanted all notes to be exactly a quarter of a beat long (sixteenth note), enter 0 for the percentage of the original length and 0.048 for the fixed offset. If you wanted each note to be half their existing length, enter 50 as the percentage and 0 for the fixed offset.

Tip: This tool can be especially useful for drum and rhythm tracks.

Legato

The Legato tool lets you set the gap between the notes, giving a smooth (legato) or choppy (staccato) style.

Input: The number of ticks to leave as the gap between notes, in beats and ticks. Enter the number of beats followed by a dot followed by the number of ticks. There are 192 ticks in a beat.

Note: Smaller gaps lead to smoother playing. Note also that sometimes Sustain pedal messages can override the effect of this tool.

Progression

The progression tool lets you insert a series of notes or controllers. For example, you can insert a series of tempo events and create ritenuto effects; or insert a series of volume control messages to create a fade effect.

In addition to a start and end point for the progression, the progression tool has an LFO (low frequency oscillator) which lets you create more complex progressions which include cyclical variations. For example, you could use the LFO settings in a progression of pan controllers to create a pan tremolo (auto pan) effect, or you could use the LFO with a progression of notes to create a siren effect.

Input: There are several inputs to this tool:

Progression type: Select the type of progression you want from the list. You can choose a progression of any controller, aftertouch, pitch bend, tempo or notes.

Channel: For all progression types except tempo, specify the MIDI channel for the events that are inserted. If you choose channel number 0, the events will use the channel specified by the track properties.

Progression start and end: These are the points for the ends of the progression. Specify these in terms of beats and ticks.

Start and end value: These are the values of the inserted events at the start and end of the progression. They can be the same value. For note progressions, the values specify the note pitch and you can enter notes either as numbers or by name; for all other progression types, the values specify the controller value.

Start and end velocity: For note progressions, these set the start and end velocity values for the notes. Velocity is not used for other progression types.

Snap: Specifies in beats and ticks how often to insert an event.

Note length: For note progressions, enter the length of the inserted notes in terms of beats and ticks. This setting is not used for other progression types.

LFO to value: When selected, this checkbox makes the LFO apply to the main progression values. For notes, it applies to the pitch of the notes.

LFO to velocity: For note progressions, with this checkbox checked, the LFO applies to the velocity of the notes.

Note: with both of the LFO to value and LFO to velocity checkboxes unchecked, the following LFO settings will have no effect.

LFO wave: Selects the pattern for any cyclical variations added to the progression. Several waves are available, including sine, triangle, saw, square, pulse and random.

LFO amplitude: Enter the maximum amount the LFO will contribute to the progression. For example, for a note progression, an amplitude value of 12 will vary the notes by up to an octave (12 semitones up or down). An amplitude of 0 effectively turns off the LFO.

LFO rate: Enter the time, in beats and ticks, for one cycle of the LFO.

LFO phase: Normally, the LFO waves start at zero, and goes up, before going down and then returning to zero. The phase control allows starting the cycle at other points. For example the sine wave normally starts at 0, is 1 at 90 degrees, 0 at 180 degrees and -1 at 270 degrees. So if you set the phase to 90, then the cycle starts at 1.

Filter duplicate events: With this checkbox unchecked, a MIDI event is always generated at every snap position, regardless of if the event is the same as the last one. With this checkbox checked, an event is only generated if it is different from the previous one.

Note: Some progression types may not produce meaningful results.

Note: If you have the MIDI in dialogs option selected, you can play the starting and ending notes on your MIDI instrument for a note progression. If you do this, both the key and velocity will be set.

Insert From File

The Insert From File tool lets you insert a track from another MIDI file at the current position. This can be useful, for example, if you have a library containing musical patterns or effects which you want to use in your composition.

Input: First, choose the file which contains the track you want to insert using the File Open dialog. A list of tracks in the file is then displayed, choose the one you want from the list and select if you want to insert or merge the track into your song. Insert will move existing data to make room for the inserted track, merging will simply add the new material on top of any existing data.

Cleanup

The Cleanup tool performs several tasks to tidy up MIDI data: It deletes doubled notes; inserts missing note off messages, and, if necessary, inserts missing pedal up and pitch bend reset messages at the end of a track.

Input: This tool has no user input.

Note: This tool operates only on the entire track. Even if you select a region in a track, the Cleanup tool will still clean the whole track.

Note: There is an Option to automatically call this tool whenever you load a song.

Set Channel

The Set Channel tool sets the MIDI channel of all events to the channel you specify.

Input: The MIDI channel number to set all events to, in the range 1 to 16.

Note: The channel set in the Track Properties will override any channel information stored in the track. To allow the channel specified by events in a track to operate, set the channel in the Properties to 0.

Channel Split

The Channel Split tool takes a MIDI track containing data for several different MIDI channels and splits it into several tracks each containing data for just one MIDI channel.

This tool may be particularly useful when working with Type 0 MIDI files. After loading the file, use the Split Channel tool to put each part into its own track.

Input: This tool has no user input.

Note: This tool always operates on the current track only, regardless of the setting of the Apply to All Tracks option.

Key Split

The Key Split tool allows you to specify a note range. Then, all notes within this range are placed in a new track. Notes outside the range are placed in a second new track.

Input: Enter the lower and upper notes to form the range of notes you wish to place in the first track. Middle C (note C4) is number 60. You can enter either note names or note numbers. Alternatively, if you have the MIDI in dialogs option turned on, you can play the notes on your MIDI instrument.

Note: This tool always operates on the current track only, regardless of the setting of the Apply to All Tracks option.

Velocity Split

The Velocity Split tool allows you to specify a velocity range. Then, all notes within the velocity range are placed in a new track. Notes outside the range are placed in a second new track.

Input: Enter the lower and upper velocities to form the range of notes you wish to place in the first track.

Tip: One use for this tool is to place loud notes into a separate track so you can use a different instrument to play them, for example an ordinary bass and a slap bass for loud notes.

Note: This tool always operates on the current track only, regardless of the setting of the Apply to All Tracks option.

Length Split

The Length Split tool allows you to specify a note length range. Then, all notes within the note length range are placed in a new track. Notes outside the range are placed in a second new track.

Input: Enter the lower and upper note lengths to form the range of notes you wish to place in the first track.

Note: This tool always operates on the current track only, regardless of the setting of the Apply to All Tracks option.

Note Replace

The Note Replace tool allows you to change all occurrences of a particular note to a different note.

Input: Enter the note to change and the new note to use instead. You can enter either note names or note numbers. If you have the MIDI in dialogs option turned on, you can also just play the notes on your MIDI instrument.

Tip: One use for this tool is when working out harmony parts. For example, first take a melody line. Make a copy on a new track then Transpose the new track to form a rough outline for the harmony. Then, use the Note Replace tool to change some of the transposed notes so that they are back in the right musical scale.

Velocity Crescendo

The velocity crescendo tool can be used to adjust the velocities of notes so they create a crescendo or diminuendo effect.

Input: This tool takes as input the final velocity adjustment (as a percentage). To make a crescendo, enter a value above 100; for a diminuendo, use a value below 100.

Note: This tool is not the same as using controller 7 or 11 to add a fade effect.

Controller Renumber

The Controller Renumber tool lets you change all occurrences of a particular controller with another.

Input: Enter the number of the controller to change and the new controller number to use instead. Controllers are numbered from 0 to 127.

Tip: This tool can be useful, for example, if your MIDI keyboard can only transmit certain controllers, but you wish to use a different one; for example, assume your keyboard can only transmit Volume messages (controller 7) but you wish to use Expression (controller 11).

Note: Incorrectly changing controllers can lead to undesirable results.

Change Controllers

The Change Controllers tool lets you modify the values of MIDI controller data. The effect of this will vary on the number of the control you modify.

Input: First, enter the number of the control to change values for. Enter numbers 0 to 127 for the ordinary controllers, 128 for Program Changes, 129 for Aftertouch, 130 for Pitch Bend or 131 for Tempo messages.

Secondly, enter the two parameters to define how to change the controller values. The new value is calculated as a percentage of the existing value, plus a fixed offset.

Note: The allowable range for controller values depends on the controller: for standard Controllers, Program Changes and Aftertouch (0-129), the allowable range is 0 to 127. For Pitch Bend (130) the range is -8192 to +8191. For Tempo (131) the range is 10 to 480. Any controller values which would result outside of these ranges will be limited to the range.

Reverse

The Reverse tool reverses the order of the MIDI events. This includes all events, including notes and controllers. The effect is to play the data backwards.

Input: This tool has no user input.

Note: In order to accurately position notes, the Reverse tool switches over the start and end positions of the notes. Be aware that if you originally had a chord (notes starting at the same time), but the notes finishing at different times, once you have reversed it the chord may sound ragged (because the notes now all start at different times but finish together).

Delete Notes

The Delete Notes tool allows you to remove all notes in a particular key range.

Input: Enter the lower and upper note numbers for the range of notes to be deleted. Middle C (note C4) has number 60.

Tip: You may also find the Key Split tool useful, as it puts a range of notes into a separate track.

Delete Controllers

The Delete Controllers tool removes all occurrences of a particular type of controller. For example, you can remove all Modulation messages or Sustain pedal messages.

Input: Enter the number of the controller you wish to delete. Standard Controllers are in the range 0 to 127. You can also enter 128 to delete Program messages, 129 to delete Aftertouch, 130 for Pitch Bend or 131 for Tempo messages.

Note: Controllers can form a vital part of some performances, so deleting them may lead to strange results.

Apply to All Tracks

The Apply to All Tracks option is not a tool itself, but determines whether the tools affect the current track or operate on all tracks.

With Apply to All Tracks turned off, all the tools operate on the current track only.

With Apply to All Tracks turned on, the tools will operate on all tracks (except muted tracks). The only tools which do not do this are Channel Split, Key Split and Velocity Split.

Muting tracks is a useful way to prevent tools operating on tracks which should not be affected. For example, let's assume you have a complete song and you wish to transpose it up a key. First, choose Apply to All Tracks to turn this feature on. Then, make sure that all tracks are not muted. Then, mute any drum tracks: transposing these will lead to very interesting but not ideal results. Finally, choose Transpose to perform the key change. Last of all, choose Apply to All Tracks a second time to turn the feature off again.

Editors

The various editors in QWS allow you to inspect and modify MIDI data at a far greater level of detail than the main view.

There are four editors in QWS:
· The Event list
· The Note editor
· The Control editor
· The System Exclusive editor

These are explained in the following sections.

For all editors, with the exception of the System Exclusive editor, when you first enter the editor, you will see the MIDI data for the current track at the current position. You can move around within the editors, but when you exit, the current position will still be in the same place. This can often be useful as you can make a change and then play the song again from the same point.

The System Exclusive editor is only accessed from the Event list when you edit a system exclusive message.

Note: If you make a mistake with an editor, you can come out of the editor and use the Undo command to undo your changes.

The Event List

The event list is the simplest of the editors in QWS. It shows a list of all the MIDI events in a beat. The list is written out in columns as follows:

At the left is the time position of the event, in beats and ticks. The first beat is number 0 and there are 192 ticks in a beat.

Next is the MIDI event type (or status), such as Note On, Pitch Bend, Tempo etc.

Third is the MIDI channel number (from 1 to 16). Some events, such as tempo events, time signatures and system exclusive messages, do not have a MIDI channel, so this column can be blank.

The remaining columns are the data associated with the event. The number of data items will vary depending on the event type, but for most events there are two columns, the number and value. For example, in the case of Notes, these show the key number and the velocity value.

The last column in the case of notes is the note length, again written in beats and ticks.

For system exclusive messages, you will see the size of the message and the first few values of the message. These values are the raw MIDI data of the event. It can be useful to help identify the exact message.

To move around in the Event List, use the Back and Next buttons to the right of the main list, or press PGUP or PGDN.

The Insert and Delete buttons allow you to create new events or remove events from the list. When you insert an event, you will be asked for the event type. Select from the list and choose the OK button.

You can also use the following keys to edit events in the Event List:

S - edit the start position.

C - Edit MIDI channel.

N - Edit data number (first data item) (or edit a system exclusive).

V - Edit data value (second data item).

L - Edit length (only for notes).

To close the editor, choose the Close button to the right of the main list. The changes you make are saved as you go along, so if you decide afterwards that you do not wish to keep them, use the Undo command.

The Note Editor

The Note Editor is designed to allow you to manipulate all aspects of MIDI notes in a detailed manner.

The main portion of the display is the Note View. At the left of this is a key scale, showing the note range currently in view. Vertical lines in the view show the position of beats. Notes are represented by horizontal bars.

At the bottom of the display is the status bar. This shows information about the current position or currently highlighted note. You can either press the initial letter of each field on the status bar, or click the various portions on the status bar to edit each attribute. For example, to edit the start time of a note, press S or click Start on the status bar. At the extreme right of the status bar is either the word "ins" or "mod". This is a check so that you know whether or not the cursor is on a note or not. If it says "ins", you may insert a new note; if "mod" appears, then changes you make to the note attributes will modify the currently highlighted note.

The buttons to the right of the Note View are used to perform the editing. The Insert button will insert a note with all the attributes shown on the status bar. This will only work if the cursor is not already on a note.

The Edit button will call up a dialog allowing you to change the currently selected note attribute, shown on the status bar. For example, to change the start time of a note, choose Start from the status bar, then choose Edit. If the cursor is highlighting a note when you press Edit, the current note will be altered. Otherwise, the information on the status bar alone will change.

The Delete button will remove the currently highlighted note.

The Memo button will "memorise" the currently highlighted note, so when you move off it, the status information will stay the same. This can be useful if you wish to insert several notes with similar properties.

When you navigate around the Note View (either with the keyboard or the mouse) notice that the cursor jumps by a certain number of ticks, 48 by default (one quarter of a beat). This is the Snap value. It does not affect playback, but can greatly speed editing. Press the Snap button to change the snap value. Bear in mind that there are 192 ticks in a beat.

In addition to the buttons and shortcuts mentioned so far, you can also use the following keys in the Note View:

F5 - Decrease current attribute.

F6 - Increase current attribute.

F7 - Decrease in larger steps.

F8 - Increase in larger steps.

ALT+RIGHT - Jump to next note.

ALT+LEFT - Jump to previous note.

The increment/decrement keys will change the value of the attribute currently highlighted in the status bar. If there is a note highlighted, the note will also be altered. For example, to change the pitch of a note up by one octave: highlight the note to change, choose Key on the status bar (click Key or press K) then press F8.

To finish editing, choose the Close button to return to the main view.

The edits you make in the Note Editor are applied to the current track as you make them. If you decide to abandon your editing, come out of the editor and use the Undo command.

The Control Editor

The Control Editor is very similar to the Note Editor and shares the same general operation, keys and layout. The Control Editor, however, lets you edit MIDI controllers including Control Change messages, Program Changes, Aftertouch, Pitch Bend and Tempo messages.

Instead of using horizontal bars to represent notes, the Control Editor uses small squares. This is because controllers do not have a length as notes do, but rather occur at a single specific time.

On the status bar at the bottom, you will see similar items to those in the Note Editor. The Value shows the current setting for a controller. The allowable range for a controller depends on the type of controller.

The Num attribute on the status bar shows the currently selected controller type shown in the editor. You can only see one type of controller at a time. The meaning of Num is as follows:

0-127 - MIDI Control Change messages 0 to 127.

128 - Program Change messages.

129 - Aftertouch.

130 - Pitch Bend.

131 - Tempo.

For example, let's insert a Program Change message at the start of beat 16 in the current track. First, choose Num on the status bar (either by clicking it or by pressing N). Choose Edit and enter 128. The Control View now shows Program Change messages (it may be blank if there currently aren't any). Next, Choose Start from the status bar (by clicking it or by pressing S). Choose Edit and enter 16 to move to beat 16. Next, choose Value from the status bar (click it or press V). Choose Edit and enter the number of the Program Change you want. Finally, press Insert (or press I or the INSERT key) to insert the controller.

To finish editing, choose the Close button.

As with all the editors of QWS, the changes you make are immediately applied to the current track. If you decide to cancel them, close the editor and then use the Undo command.

Note: Although the initial settings for each track contain control settings, these are not shown in the Control Editor. To set initial settings for a track, use the Track Properties command.

The System Exclusive Editor

The System Exclusive editor lets you edit the data sent in MIDI System Exclusive messages. You access this editor by selecting a System Exclusive message from the Event List and choosing to edit.

System Exclusive messages can be complex, but allow fine level control of your MIDI instrument. For example, with a synthesiser, you may be able to create new sounds (patches), change settings of effects or modify the mode of operation of the synth. 

The display of the System Exclusive editor is simple: the main part shows the data of the message, in hexadecimal. To the right are OK, Cancel and Send buttons. To the left of the data is an offset number, which simply helps show where you are in the data.

To edit, use the normal movement keys and the 0-9 and A-F keys to enter data. Insert or delete values using the INS or DEL keys.

In addition, you can use the following keys to increase or decrease a value:

F5 - Decrease by 1.

F6 - Increase by 1.

F7 - Decrease by hex 10.

F8 - Increase by hex 10.

When editing, it is important to remember that:
All System Exclusive messages must start with the value F0.
All System Exclusive messages must finish with the value F7.
All the values between the F0 and F7 must be between 00 and 7F.

You will not be able to choose OK unless these conditions are met.

The Send button sends the data shown in the editor to your synth, so you can try the effect of the message before you OK it.

For detailed information about the messages your MIDI equipment responds to, consult the manual(s) for your equipment.

Configuring QWS

There are many ways in which you can configure QWS. These range from whether you want the toolbar or status bar to appear on screen to more advanced settings like the MIDI messages to use for sounding the metronome.

Most of the configuration commands are found on the Options menu. The following sections explain these.
· Screen appearance
· Metronome Settings
· Key Commands
· Instrument Lists
· MIDI Assignments
· Port Manager
· Onscreen Keyboard
· General Options
· Making instrument Lists
· Translating QWS

Screen Appearance

Use the commands in the View menu to configure how the main screen of QWS appears.

The Toolbar and Status Bar commands set whether the toolbar and status bar are displayed or not.

The Zoom command allows you to set how many beats are represented by each character in the main track view. By default the zoom is set to 4. You could adjust this, for example, to a lower value in order to have a more precise display. Alternatively, use a higher zoom number to show the general picture of the song.

The Display Units submenu in the View menu allows you to select how the song position will be displayed in the status bar: choose between position (beat numbers), bar and beat numbers or time. Note that in order for the bar or time values to be accurate, all tempo or time signature changes should be on the first track. Note also that the chosen display unit only applies to the status bar, tools and editors use song positions.

Metronome Settings

The Metronome command on the Options menu lets you adjust the MIDI settings used to sound the metronome. When you choose this command, a dialog will appear allowing you to specify the MIDI channel, port, key and velocity used for first beats and other beats.

In most cases, you will probably use MIDI channel 10 (normally set to a drum kit) for the metronome. The sound each key will make may depend on your MIDI keyboard, but in General MIDI, key 37 (C#2) is a side stick which may be useful. Some keyboards may also have dedicated metronome sounds (for example on keys A#1 and A1).

In addition to setting the sounds used for the metronome, the metronome dialog also lets you set the countdowns which occur before playback or recording. Before you play or record, the metronome will count this number of beats before playback starts. This may be especially useful when recording to get a feel for the timing.

Tip: Use the Metronome command on the MIDI menu to turn sounding the metronome on or off. The word "Metro" will appear on the status bar if the metronome is switched on.

Key Commands

Key commands allow you to put some of the QWS commands on keys of your MIDI keyboard. This gives you the option to "remote control" QWS, especially useful if your keyboard is some distance from your computer.

To set Key Commands, choose the Key Commands command from the Options menu. This calls up a dialog with two lists. On the left is a list of MIDI keys (note that your keyboard may not have all of these). On the right is a list of all the functions you can assign to keys.

As you select each key on the left, the current Key Command assignment is shown on the right.

To change a Key Command, simply choose another function from the list on the right. Choose OK to activate your changes.

Note: If a key on your keyboard is assigned a Key Command, the note the key normally produces will no longer be sounded, Key Commands take priority.

Instrument Lists

Instrument Lists allow you to choose the instruments (patches) for your MIDI keyboard by name, rather than by entering numbers for program and bank. Instruments are shown when you use the Track Properties command to select the initial settings for each track.

Choose the Instrument Lists command on the Options menu to set the instrument list for each MIDI output port. This calls up a dialog showing a list of the available MIDI output ports on the left and a list of instrument lists on the right.

To choose an instrument list, simply select the port on the left, then the instrument you want from the list on the right. Choose OK to confirm the changes.

Note: You can download instrument lists from the QWS website and you may create your own Instrument Lists for use with QWS. See Making Instrument Lists for details.

MIDI Assignments

You can change the way QWS interprets incoming MIDI data from your keyboard by using the MIDI Assignments command on the Options menu. This calls up a dialog giving the following options:

The Transpose value is a number of semitones to adjust each note up or down as you are playing. Positive values will transpose upwards, negative values will transpose down. For example, if you wanted an extra octave of keys at the bottom of your keyboard, set the transpose value to -12 (there are 12 semitones in an octave).

The % Velocity and Velocity Offset options allow you to change the way QWS responds to your playing dynamics (loud and soft). For each note you play, the velocity (loudness) will be multiplied by the percentage, then the offset will be added, in a very similar way to how the Change Velocity tool operates.

For example, for normal operation use a percentage of 100 and an offset of 0. However, if you wanted a non-touch sensitive keyboard (for harpsichord or organ music, for instance), set the percentage to 0 and the offset to, say, 80.

The Control Number and Assigned To options let you change the way a control wheel behaves on your keyboard. For example, you can assign a modulation wheel (controller number 1) to control volume (controller 7) or pan (controller 10) instead. Normal operation is achieved when the controller and Assigned To values match.

The Pitch Bend settings let you change what the pitch bend lever does. You can set separate functions for moving the lever up and down. The Maximum and Minimum settings set the values of the controller you choose when the pitch bend lever is moved to the extreme (maximum) or centre (minimum) positions.

For example, if you wanted to make moving the pitch lever control pan (stereo position), proceed as follows: Set Pitch bend up and Pitch bend down both to controller 10 (pan). For pitch bend up, set the maximum to maximum and the minimum to halfway. For pitch bend down, set the maximum to minimum and the minimum to halfway. This now means that when you move the pitch bend lever up, pan moves from centre to fully right (maximum) and when you move the pitch bend down, pan moves from centre to fully left (minimum).

Caution: Some settings may mute the sounds from your keyboard! You may find it useful to consult your keyboard manual to determine what each controller does.

Port Manager

Choose the Ports command from the Options menu to call up the Port Manager.

The Port Manager lets you assign names for the various MIDI ports you have on your computer and to set whether QWS uses each port.

From the list of ports, choose a port you wish to alter. Then type in a "friendly" name for the port to change its name. Tick or clear the Use This Port box to set whether QWS will use the port.

Note: If you disable all ports, QWS will not be able to operate!

Onscreen Keyboard Options

The Onscreen Keyboard command in the Options menu allows you to change the keys which are used to play notes on the onscreen keyboard.

First, select a key number to change (you can have up to 32 note keys), then press the key you want to use in the Assign To box. The Base Key box lets you select which note the first key will play.

Use the Reset to Defaults button if you want to return the Onscreen Keyboard keys to the initial defaults.

Note: By assigning notes to keys that are normally used for other functions, such as octave and velocity, you will override their normal behaviour.

General Options

Choose the General Options command from the Options menu to call up the general options for QWS.

Preferred MIDI Device: the MIDI OUT port to use for any new tracks you create. You can of course change the MIDI port a track uses at any time, but this setting chooses the default.

Playback Delay: Sets a short delay sent when you start playing a song from the beginning. You may find that some MIDI equipment responds slowly to program change messages, so this short delay can be helpful.

Follow Playback: When ticked, this option will move the caret in the track view in time with recording and playback. This can help show progress through song playback.

Confirm Keep Recordings: If ticked, when you finish a recording session, a confirmation box will appear, giving you the option to keep or cancel the recording.

MIDI In Dialogs: If ticked, this option lets you hear the effect of changing the settings in dialogs such as Track Properties as you make them. It also allows you to enter settings in certain dialogs using your MIDI instrument.

Keyboard Commands: Enables the Key Commands function.

Auto send local messages: When ticked, QWS will automatically send a MIDI local off message when you start QWS and a local on message when you close QWS.

Loading options

Scan Method For Initial Settings: Sets which method to use to establish the initial settings for each track. These settings are only of real importance if you import MIDI songs not created in QWS. There are three methods available: Time 0 will only use settings which occur at the start of the first beat. Before Notes will take the first settings wherever they occur, so long as no notes have yet been found. First Available will take the first settings found, even if they occur after a note.

Auto Send Messages: Whenever you load a song, you can automatically send MIDI messages to your equipment to prepare it for the new song. The choices are not to send anything (None), or to send a MIDI Reset or the initial track settings (see Restoring Settings).

Auto Cleanup: This option automatically calls the Cleanup Tool when you load a song.

Making Instrument Lists

Instrument lists are contained in files stored in the same folder as QWS. When you load QWS, it looks for instrument list files in the same folder as the QWS program. You may create or modify instrument list files using an ordinary text editor. Follow these instructions.

Possibly the best starting point is to load an existing instrument list file and make your changes - but be sure to save to a new file.

Any line starting with a semicolon (;) is a comment and is ignored by QWS. However, it is a good idea to add comments to instrument lists.

The first important line is [instruments]. QWS begins reading after this line.

The line that starts name= gives the name that QWS will display for the list. This line must be present for QWS to recognise the file as an instrument list.

After this is the list of instruments: their names together with the MIDI bank and program numbers. On some MIDI instruments, certain settings only apply to specific channels, such as drum kits only on MIDI channel 10. This is also contained in the instrument lines.

Each line starts with the required MIDI channel (-1 if not applicable), then the program number, the bank number (-1 if not applicable) and finally the instrument name. The fields are separated by commas.

For example, here's the beginning of the GM2 instrument list:

; GM2 instrument list for QWS
; Format is chan, prog, bank, name
[instruments]
Name=GM2 Instrument
-1, 0,15488,Acoustic Grand Piano
-1, 0,15489,Wet Acoustic Grand
-1, 0,15490,Dry Acoustic Grand
-1, 1,15488,Bright Acoustic Piano
-1, 1,15489,Wet Bright Acoustic
-1, 2,15488,Electric Grand Piano
-1, 2,15489,Wet Electric Grand
-1, 3,15488,Honky-tonk Piano
...

When you have finished editing, save the instrument list. Be sure to give the file a .INI file extension. QWS will automatically look for instrument list files when you run it, so to make QWS load your new list, all you have to do is restart QWS.

It is worth checking that everything has worked. To do this, choose the Instrument Lists command in the Options menu. Your new list should be listed. Then, select it for a MIDI port and try it by selecting the Properties command on the Track menu.

If your list appears blank in the list of instrument lists, or has the word "loading error" after the name, it has not loaded properly. If this happens, reload your file in the text editor and check.

Making Note Transforms

You may add your own note transforms for use with the Note Transform tool. These are stored in a file called userxfrm.ini in the same folder as QWS. You can edit this file in an ordinary text editor. The preset note transforms are in the file notexfrm.ini but you should not modify this file as it could be overwritten by upgrading QWS.

Possibly the best starting point for creating a new note transform is to copy one of the preset note transforms.

In userxfrm.ini, any line starting with a semicolon (;) is a comment and is ignored by QWS.

The line [notexfrm] marks the beginning of the note transforms.

Each transform then has a namex=... and xfrmx=... line. The name is the displayed name for transform x. The xfrm line gives a list of 128 numbers showing how each of the 128 MIDI notes are transformed. The first number is where MIDI note 0 (C-1) is moved, the next, for note 1 (C#-1) and so on.

For example, here is a note transform that maps notes to the nearest note C:

; User note transforms for QWS
[notexfrm]
Name0=Nearest C
xfrm0=0,0,0,0,0,0,0,12,12,12,12,12,
12,12,12,12,12,12,12,24,24,24,24,24,
24,24,24,24,24,24,24,36,36,36,36,36,
...
108,108,108,108,108,108,108,120,120,120,120,120,
120,120,120,120,120,120,120,120

When you have finished editing, save the note transforms as userxfrm.ini. QWS will automatically load the note transforms files when you run it, so to make QWS load your user note transforms, all you have to do is restart QWS.

It is worth checking that your note transforms work. To do this, create a progression of notes with the Progression tool. Then apply your note transform and check you get the expected results.

If, when you start QWS you receive an error message saying there is a problem with one of your note transforms, please make sure that the transform data contains exactly 128 numbers and that each number is in the range 0-127. Also make sure that all 128 numbers are on the one line (i.e. there should not be any carriage returns in the data).

Translating QWS

It is possible to translate QWS into other languages. If you need details of how to do this, please contact the author. Also, check the QWS website in case the translation has already been made.

Menu Commands

Most of the features in QWS are available from the program menus. This section reviews the menu commands.

The File menu contains commands for loading and saving your song.

The Edit menu contains commands for basic editing (such as copy and paste).

The View menu contains commands for how the QWS screen should appear.

The Goto menu contains commands for setting up markers in your song and for quickly jumping around in the song.

The Tools menu contains commands for manipulating MIDI data. This includes transposing, quantising and gliding.

The Play menu contains the commands for playing and recording.

The Track menu contains commands for manipulating tracks.

The MIDI menu contains commands relating to MIDI.

The Options menu contains commands which let you configure QWS.

The Help menu contains commands for getting help with using QWS.

QWS also supports a number of shortcut keys to make using QWS faster and more convenient. These keys make several QWS functions available without using the menu. These keys are shown, where available, to the right of each menu item. For example, the Metronome command on the Play menu also says F4. This means you can press the F4 key as an alternative to using the menu. A full list of the keys can be found in the shortcut keys section.

QWS can also be run from the command line.

File Menu

The File menu contains commands for loading and saving your song:

New: Clears all tracks and creates a new blank song. If you haven't saved your existing song, you will be prompted.

Open: Allows you to open a different song.

Append: Allows you to open another song whilst keeping all the existing tracks.

Save: Allows you to save the current song.

Save As: Allows you to save the current song with a new name.

Song Properties: Lets you enter a title and copyright information for the song. These are optional and for information only.

1...8: The numbered items give a quick way to reload songs you have recently worked with. The most recent file is number 1 with older files moving down the list.

Exit: Closes QWS. If you haven't saved your existing song, you will be prompted.

Edit Menu

The Edit menu contains commands for basic editing:

Undo: Allows you to reverse the last thing done. Please note, only one operation can be undone. If you press Undo a second time, the operation will be redone.

Cut: Deletes the selected part of a track and puts it in the QWS clipboard.

Copy: Takes a copy of the selected part of a track and puts it in the QWS clipboard.

Paste: Pastes the clipboard information into the current track at the current position.

Paste Multiple: Pastes the clipboard information into the current track at the current position a number of times.

Merge: Merges the clipboard information with the current track at the current position.

Merge Multiple: Merges the clipboard information with the current track at the current position a number of times.

Select All: Selects the entirety of the current track.

Select Marked: Selects between the Left and Right markers if you have them set.

Delete: Deletes the selected part of the current track.

Clear: Deletes all events from the selected part of the current track, leaving space where it was.

Controllers: Starts the Controller Editor.

Notes: Starts the Note Editor.

Event List: Starts the Event List Editor.

View Menu

The commands in the View Menu allow you to configure the appearance of the QWS screen.

Toolbar: Selects whether to display the command toolbar at the top of the main screen.

Status bar: Selects whether to display the status bar at the bottom of the main screen.

Zoom: Sets the number of beats per character in the track view.

Display Unit: Sets how song position is displayed in the status bar: choose from position (beat numbers), bar numbers and time.

Goto Menu

The commands in the Goto Menu allow you to set up markers to specific points and to quickly jump around your song.

Find: Lets you search for a particular MIDI event.

Find Next: Repeats the last search from the current position.

Goto: Lets you jump to a new position in the song.

Track: Lets you jump to a different track.

Set Marker: Lets you set a marker at the current song position.

Clear Marker: Lets you clear a marker.

Clear All Markers: Lets you reset all markers.

Prev Marker: Moves backwards to the previous marked position.

Next Marker: Moves forwards to the next marked position.

Goto Marker: Lets you jump to a marker.

Sort Markers: Sorts the markers into order.

Tools Menu

The Tools menu contains commands for manipulating the selected part of the current track. If there is no selection, the tools will act on the entire track:

Transpose: Allows you to adjust the key of the selection up or down a number of semitones.

Change Velocity: Allows you to change the loudness of the notes in the selection.

Time Glide: Allows you to move the selection back or forward.

Time Expand: Allows you to change the speed of the selection.

Quantise: Moves notes so that they are "on the beat". Good for getting things in time.

Quantise Length: Adjusts note lengths so that they are more exact. Good for getting things in time.

Humanise: Opposite to Quantise, i.e. randomly adjusts the time of each note. Good for removing the mechanical feel of Quantise.

Set Length: Adjusts the length of notes.

Legato: Sets the length of the gaps between notes, giving a smooth (legato) or choppy (staccato) style.

Progression: Inserts a series of note or controller messages. This can be used to insert many effects, such as fade or ritenuto.

Insert From File: Insert a track from another MIDI file. Useful to add patterns or effects from a library.

Cleanup: Tidies up a track: adds missing messages, prevents overlapping notes etc.

Set Channel: Sets the MIDI channel of all events to the channel you specify.

Channel Split: Splits a multichannel track into several single channel tracks.

Key Split: Extracts a range of notes into one track and notes outside the range into a second track.

Velocity Split: Extracts notes with a given velocity range into one track and puts notes outside the range into a second track.

Length Split: Extracts notes with a given length range into one track and puts notes outside the range into a second track.

Note Replace: Changes one note for another. Useful for changing drums or creating harmony parts.

Velocity Crescendo: Adjusts note velocities to achieve crescendo or diminuendo effects.

Controller Renumber: Allows you to change controllers of one type for another type, for example, change Volume to Expression.

Change Controller Values: Allows you to manipulate the values of controllers, for example, to increase Modulation.

Reverse: Reverses the order of MIDI events, so the music plays backwards.

Delete Notes: Deletes all notes in a certain key range.

Delete Controllers: Deletes all controllers of a particular type.

Note Transform: Performs a variety of note replacements, such as major to minor and mirror.

Apply to All Tracks: Selects whether the tools operate on just the current track or on all tracks which are not muted.

Play Menu

The Play menu contains commands for playing and recording:

Play/Stop: Plays the song from the current position. If the song is already playing or recording, this command will stop.

Record: Starts realtime recording.

Step Record: Starts step recording.

Loop: Toggles the looping function. If you set Left and Right markers and enable Looping, when playback reaches the Right marker, the song will automatically jump back to the Left marker.

Punch Recording: With Punch Recording selected, when you record, recording will only take place between the Left and Right markers.

Synchro Start: Toggles the Synchro start function. When turned on, QWS will start song playback or recording when you start playing on your MIDI instrument.

Send Initial Settings: Sends the initial MIDI settings stored in each track's Properties.

Send Current Settings: Sends the most recent MIDI settings based on the current song position.

Initial Time & Tempo: Sets the initial time signature and tempo for the song.

Track Menu

The Track menu contains commands for manipulating tracks:

Insert: Inserts a new track.

Delete: Deletes the currently selected track. Be careful.

Move: Allows you to move a track to a different position, so changing the track order.

Initial Properties: Allows you to set the initial MIDI settings for the selected track and give the track a name.

Change Properties: Allows you to change the MIDI settings for the selected track at the current position.

Sort: Sorts all tracks into order.

Set All Ports: Lets you change the MIDI OUT port for every track to a port you choose.

Mute: Mutes or unmutes the current track.

Solo: Solos or unsolos the current track.

Unmute All: Unmutes and unsolos all tracks.

Statistics: Provides a summary of the MIDI content of the current track.

MIDI Menu

The MIDI menu provides commands relating to MIDI:

All Notes Off: Use this to turn off any notes that "get stuck".

GM Reset: Sends a GM Reset MIDI message to initialise your keyboard.

GM2 Reset: Sends a GM2 Reset MIDI message to initialise your keyboard.

GS Reset: Sends a GS Reset MIDI message to initialise your keyboard.

XG Reset: Sends an XG Reset MIDI message to initialise your keyboard.

Local Off: Sends a Local off MIDI message to each MIDI OUT port.

Local On: Sends a Local on MIDI message to each MIDI OUT port.

Onscreen Keyboard: Allows you to simulate MIDI IN using the mouse or computer keyboard.

Metronome: Turns the metronome on or off.

MIDI THRU: Turns the MIDI THRU feature on or off.

MIDI Clock: Turns sending a MIDI clock signal on or off.

Options Menu

The commands on the Options menu allow you to configure QWS:

Metronome: Allows you to set up how the metronome will sound.

Key Commands: Allows you to set up keys on your MIDI keyboard to control QWS, for example you could make the top C key start and stop playback.

Instrument Lists: Allows you to assign instrument lists to each available MIDI output port. Instrument lists are a convenient way to pick instruments for your song by name, rather than by MIDI program and bank number.

MIDI Assignments: Allows you to set how MIDI messages received from your keyboard will be interpreted. For example, you can transpose, change touch sensitivity, or even alter what the pitch bend lever does.

Ports: Calls up the Port Manager where you can change the names QWS uses for the various MIDI ports on your computer and set whether each MIDI port will be used by QWS.

Onscreen Keyboard: Allows you to change the keys used for notes in the onscreen keyboard.

General Options: Provides access to the general configuration options for QWS.

Help Menu

The Help menu allows you to get help with using QWS:

Contents: Shows the contents for the online help.

Tip of the day: Shows the next tip of the day.

QWS on the web: Calls up the QWS website using your internet browser.

About QWS: Shows the version information for QWS.

Shortcut Keys

In addition to accessing the functions of QWS through the menus, there are many shortcut keys which will speed up your work. These are listed below:
	Function
	Key

	Play/Stop:
	SPACE

	Record:
	CTRL+R

	Step record:
	CTRL+E

	Synchro start:
	CTRL+Y

	Mute track:
	M

	Solo track:
	S

	Unmute all tracks:
	CTRL+U

	MIDI THRU on/off:
	CTRL+H

	Insert beats:
	INS

	Delete beats:
	DEL

	Insert track:
	CTRL+INS

	Delete track:
	CTRL+DEL

	Track properties:
	ALT+ENTER (or ENTER in the Track List)

	Initial tempo and time signature:
	CTRL+T

	Looping on/off:
	O

	Punch recording on/off:
	P

	Jump to marker Left Right 0-9:
	L R 0-9

	Set marker Left Right 0-9:
	SHIFT+L R 0-9

	Previous marker:
	CTRL+F5

	Next marker:
	CTRL+F6

	Find:
	CTRL+F

	Goto:
	CTRL+G

	Send initial settings:
	CTRL+Q

	Send current settings:
	CTRL+W

	Transpose:
	T

	Quantise:
	Q

	Change velocity:
	V

	Help:
	F1

	Find next:
	F3

	Metronome on/off:
	F4

	Decrement value (in editors):
	F5

	Increment value (in editors):
	F6

	Decrement value by large step (in editors):
	F7

	Increment value by large step (in editors):
	F8

	All notes off:
	F9

	Onscreen keyboard:
	F11

	Undo:
	CTRL+Z

	Cut:
	CTRL+X

	Copy:
	CTRL+C

	Paste:
	CTRL+V

	Merge:
	CTRL+SHIFT+V

	Select all:
	CTRL+A

	Select marked:
	CTRL+M

	Control editor:
	CTRL+J

	Note editor:
	CTRL+K

	Event list:
	CTRL+L

	New song:
	CTRL+N

	Open song:
	CTRL+O


… and don't forget:
	Save:
	CTRL+S



Command Line

If you run QWS from a command line, you can use the following parameters to control how QWS operates.

The full QWS command line syntax is: 

QWS [/F] [/O] [/P] [/Q] [/R] [/?] [file]

/F Run even if QWS is already running (don't find previous copy).

/O Check translation prompt file.

/P Play immediately.

/Q Quit after playback.

/R Register file types.

/? Display command line help summary.

file Name of a file to load.

Registering the file types means that MIDI (.mid) and System Exclusive (.syx) files will be associated with QWS in Windows Explorer. This means that you will be able to run QWS and load a file simply by clicking the file in Windows Explorer.

Quick Reference

This section contains some charts you may find useful when using QWS.
· Note Lengths lists some note lengths in terms of beats and ticks.
· Quantise Numbers gives some examples of quantisation beat divisions.
· Note Names shows how to enter note names.
· MIDI Key Numbers gives some examples of the numbers which correspond to keys.
· MIDI Controller Numbers lists the most common MIDI Controllers.

Note Lengths

In QWS, lengths of notes are given in terms of beats and ticks. There are 192 ticks in a beat. Thus, if you wanted a note length of one and a half beats, you would say 1 beat and "half of 192" ticks, i.e. 1 beat and 96 ticks.

When entering note lengths, separate the number of ticks from the number of beats with a dot.

The following table lists some common note lengths in terms of beats and ticks:
	Note Length
	Value

	Whole note (semibreve)
	4.000 (or) 4

	Dotted half note (dotted minim)
	3.000 (or) 3

	Half note (minim)
	2.000 (or) 2

	Dotted quarter note (dotted crotchet)
	1.096 (or) 1.96

	Quarter note (crotchet)
	1.000 (or) 1

	Dotted eighth note (dotted quaver)
	0.144

	Triplet quarter note (triplet crotchet)
	0.128

	Eighth note (quaver)
	0.96

	Dotted sixteenth note (dotted semiquaver)
	0.72

	Triplet eighth note (triplet quaver)
	0.64

	Sixteenth note (semiquaver)
	0.48

	Triplet sixteenth note (triplet semiquaver)
	0.32

	Thirty-second note (demisemiquaver)
	0.24



Quantise Numbers

In QWS, the quantise and quantise length tools ask for a beat division. This is the number of points to divide a beat into.

The following table lists some common beat divisions in terms of the numbers used for the quantise tools:
	Note Length
	Value

	Quarter note (crotchet)
	1

	Eighth note (quaver)
	2

	Triplet eighth note (triplet quaver)
	3

	Sixteenth note (semiquaver)
	4

	Triplet sixteenth note (triplet semiquaver)
	6

	Thirty-second note (demisemiquaver)
	8



Note Names

In QWS, when you need to enter a note, you can do so either by entering the note name or the MIDI note number.

To enter a note name, type the letter of the note (A-G) followed by any flat or sharp signs (b or #) as needed and then the note octave number (-1 - 9). You can use upper or lower case. Spaces are ignored.

For example, middle C, MIDI note 60 is C4. The C an octave above this is C5. The B one semitone down from C5 is B4 (octaves start at C and end at B).

You can enter the following accidentals: b, bb, # or ##.

For example, the following all refer to the same note: A#3, Bb3, Cbb4.

Note: on many five octave (61 note) keyboards, the first C is actually C2.

MIDI Key Numbers

In MIDI, every note has a corresponding number. The higher the note, the higher its number. Middle C (261.6 Hz), also called C4 (the forth C on a conventional piano) has the MIDI key number 60.

In QWS, whenever you need to enter a note, you can either enter its MIDI note number, or the note name.

The following table lists some note numbers for your reference:
	Note
	Number
	Note
	Number
	Note
	Number

	C1
	24
	E1
	28
	G1
	31

	C2
	36
	E2
	40
	G2
	43

	C3
	48
	E3
	52
	G3
	55

	C4
	60
	E4
	64
	G4
	67

	C5
	72
	E5
	76
	G5
	79

	C6
	84
	E6
	88
	G6
	91

	C7
	96
	E7
	100
	G7
	103



MIDI Controller Numbers
 
MIDI controllers are used to provide additional control over the way notes are played by an instrument.

The following table lists some common MIDI controllers with their corresponding numbers. Note that your MIDI equipment may not support all of the controllers shown below, or may support other controllers not listed here. Consult the manual of your MIDI equipment for further details.
	Controller
	Description

	0
	Bank select - for use with program changes

	1
	Modulation - has various effects including vibrato

	6
	Data entry - for use with RPN and NRPN messages

	7
	Volume - sets overall volume of the part

	10
	Pan - sets the stereo position of the part

	11
	Expression - sets volume of the part

	32
	Bank select LSB - use with controller 0

	38
	Data entry LSB - use with controller 6

	64
	Sustain switch - like the sustain pedal on a piano

	91
	Effect 1 - commonly reverb

	93
	Effect 3 - commonly chorus

	98
	NRPN - select NRPN parameter, use with controller 99

	99
	NRPN - select NRPN parameter, use with controller 98

	100
	RPN - select RPN parameter, use with controller 101

	101
	RPN - select RPN parameter, use with controller 100
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